Your PHP installation appears to be missing the MySQL extension error in WordPress

I was updating my PHP from PHP 5.6 to PHP 7.2 that was recommend at the time of this writing (October 2018). Php 5.6 was working well with my WordPress and Joomla installation. When I switched to PHP 7.2 Joomla was displaying  “Failed to start application” while WordPress was displaying “Your PHP installation appears to be missing the MySQL extension error in WordPress”. This gave me a clue on the error and I knew that I was missing the PHP MySQL module in my server. I googled the problem and realised so many people were facing the same problem and went straight ahead with the solutions given. One of the solution that worked for many people was to install the missing module using the following command:

 

sudo apt-get update

Now install the module.

sudo apt-get install php7.2-mysql

 

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *

Translate »